Delay in Grades Reporting to Gradebook

Incident Report for Achieve

Resolved

Our team identified the issue causing the delay in grades reporting to the gradebook.

The team then implemented a fix and all grades are now reporting to the gradebook.
Posted Mar 12, 2026 - 13:00 EDT

Investigating

We are currently experiencing a delay in student grades appearing in the gradebook. Student grades are NOT lost. No further action needs to be taken and the grades do eventually appear.

Our technical teams are actively engaged and working on addressing the issue. We will provide an update when we have more information.
Posted Mar 12, 2026 - 11:40 EDT
This incident affected: Achieve Instructor Applications (Gradebook) and Achieve Student Applications (Gradebook).