Intermittent page load issues -- Associated with Amazon Web Services Outage
Incident Report for Achieve
Resolved
Amazon Web Services reports that all services are back online and our internal testing has confirmed that Achieve is back online and fully functional. Thank you for your patience While we worked through this with our hosting partner.
Posted Dec 07, 2021 - 20:06 EST
Update
We are continuing to work with AWS and see some signs of improvement on the time needed to load pages. We will continue to provide updates as they become available.
Posted Dec 07, 2021 - 14:34 EST
Identified
Amazon Web Services is facing a major outage that’s impacting websites and services including Achieve. We hope that all services will be restored shortly and will update this page as we have more information available.
Posted Dec 07, 2021 - 12:00 EST
This incident affected: Achieve Instructor Applications (Course Planner/Plan, Gradebook, People, Read and Practice, Reading, Campus LMS integration) and Achieve Student Applications (Course Planner/Plan, Gradebook, Read and Practice, Reading, Assessments, Campus LMS integration).