Amazon Web Services (AWS) service degradation
Incident Report for Achieve
Resolved
Amazon reported at 6:42 PM ET on 6/13/23 that their services have been restored. All Achieve systems are back to normal operation.
Posted Jun 14, 2023 - 08:50 EDT
Investigating
Amazon Web Services (AWS) is currently experiencing a service degradation. Achieve users will notice a delay in assessment scores displaying. All scores are being captured and will display when Amazon restores their services. More information regarding the AWS outage can be found on Amazon's status page https://health.aws.amazon.com/health/status
Posted Jun 13, 2023 - 16:11 EDT
This incident affected: Achieve Student Applications (Assessments).