Intermittent Latency Issues

Incident Report for Achieve

Resolved

Achieve is working as expected. The team will continue to monitor performance.
Posted Jan 13, 2026 - 09:44 EST

Monitoring

Achieve is loading as normal. Our teams are monitoring the system.
Posted Jan 12, 2026 - 17:53 EST

Investigating

We are currently investigating an issue affecting our Higher Ed users who see long load times or blank pages when attempting to access Achieve. We will share more updates as soon as they are available.
Posted Jan 12, 2026 - 16:50 EST
This incident affected: Achieve Instructor Applications (Course Planner/Plan, Gradebook, People, Read and Practice, Reading, Campus LMS integration).